Как подставить значения из одной таблицы в другую

6569
Очень неудобно, работая в Excel, «руками» переносить данные из одной таблицы в другую. Допустим, есть таблица с данными о продажах: дата отгрузки, название компании-покупателя, наименование приобретенной продукции и объем поставки в натуральных единицах.

Очень неудобно, работая в Excel, «руками» переносить данные из одной таблицы в другую. Допустим, есть таблица с данными о продажах: дата отгрузки, название компании-покупателя, наименование приобретенной продукции и объем поставки в натуральных единицах. Прайс-лист, в котором указаны цены за единицу поставляемой продукции, существует отдельно. Задача: перевести в стоимост­ное выражение ежедневные продажи, то есть интегрировать в таблицу с данными о продажах цены из прайс-листа.

Сделать это без монотонной ручной работы позволяет стандартный инструмент Excel – функция вертикального просмотра «ВПР», которая автоматически сделает выборку и подставит нужные данные. Для этого в графу отчета, которая отведена под цены, надо ввести формулу «=ВПР(искомое значение; таблица; номер столбца; интервальный просмотр)».

1. Искомое значение – ячейка с данными, по которым нужно подобрать недостающие сведения из другой таблицы. В нашем примере это ячейка с наименованием товара.

2. Таблица – здесь нужно указать диапазон ячеек из другой таблицы, по которому будет проводиться поиск. Чтобы это значение задать, достаточно будет выделить прайс-лист при помощи мышки. Тут есть одна тонкость. Чтобы «ВПР» работала корректно, в прайс-листе первой колонкой должно быть наименование товара. Если это не так, то, выделяя таблицу, которую будет использовать «ВПР» как источник подстановки, надо начать именно со столб­ца с наименованиями.

3. Номер столбца – порядковый номер столбца в прайс-листе, из которого функция выберет данные о ценах. Указать необходимо именно номер столбца от начала таблицы. К примеру, если в прайс-листе первая колонка – наименование товаров, а вторая – цена, то в функцию необходимо ввести цифру 2.

4. Интервальный просмотр – для этого аргумента функции предусмотрено только два значения: «ИСТИНА» или «ЛОЖЬ». В первом случае функция будет искать по прайс-листу не точно соответствующее наименование, а похожее. Из-за этого возможны ошибки, поэтому лучше задать «ЛОЖЬ».

После того как вы ввели функ­цию, останется только скопировать ее во все ячейки отчета о продажах.

КСТАТИ. При копировании важно учитывать, что в формуле будут меняться ссылки на ячейки. Например, если копировать вниз формулу «=A1+B1», уже в следующей ячейке она примет вид «=A2+B2». А значит, в нашем примере данные о товаре из верхней ячейки не попадут в выборку. Чтобы избежать этого, используется знак доллара $. В случае с функцией «ВПР» это может выглядеть следующим образом «=ВПР(C1;$F$1:$E$35;2;ЛОЖЬ)», где $F$1:$E$35 – защищенная от изменения при копировании ссылка на прай-лист.

Полный справочник изменений в работе главных бухгалтеров
в 2017 году

Есть вопрос? Наши эксперты помогут за 24 часа! Получить ответ Новое



Школа финансового руководителя

Самое выгодное предложение

Проверь свои знания и приобрети новые

Записаться

Самое выгодное предложение

Самое выгодное предложение

Воспользуйтесь самым выгодным предложением на подписку и станьте читателем уже сейчас

Живое общение с редакцией

А еще...

Вопрос в редакцию

Ответы на самые интересные вопросы мы публикуем в газете.

Вопрос чиновнику

Горячие линии с чиновниками проходят еженедельно.

Техподдержка

Не работает сайт или сервисы? Не приходит газета? Пишите сюда!


Опрос

Какой статус вы ставите в платежках по взносам?

  • Код 08 40%
  • Код 01 43.53%
  • Код 14 16.47%
результаты

Рассылка



© 2007–2016 ООО «Актион управление и финансы»

Редакция газеты: info@gazeta-unp.ru | Администрация сайта: online@gazeta-unp.ru Политика конфиденциальности Зарегистрировано Федеральной службой по надзору в сфере связи, информационных технологий и массовых коммуникаций (Роскомнадзор). Свидетельство о регистрации Эл №ФС77-43629 от 18.01.2011


Зарегистрируйтесь и продолжите читать статью.
Это бесплатно и займет меньше минуты.

После регистрации совершенно бесплатно Вам будут доступны:

  • 12 495 статей на самые актуальные темы
  • ежеминутно обновляемые новости для бухгалтера
  • 5710 шаблонов и форм документов для работы
  • 10 электронных сервисов
Ваш подарок: «Гид по заполнению формы 6-НДФЛ» – сборник примеров заполнения нового отчета для самых разных ситуаций.
Подарок будет отправлен на Вашу почту сразу после регистрации.

У меня есть пароль
напомнить
Пароль отправлен на почту
Ввести
Я тут впервые
И получить доступ на сайт
Займет минуту!
Введите эл. почту или логин
Неверный логин или пароль
Неверный пароль
Введите пароль
×
Чтобы скачать файл, зарегистрируйтесь.
Это бесплатно и займет меньше минуты.

После регистрации совершенно бесплатно Вам будут доступны:

  • 12 495 статей на самые актуальные темы
  • ежеминутно обновляемые новости для бухгалтера
  • 5710 шаблонов и форм документов для работы
  • 10 электронных сервисов
Ваш подарок: «Гид по заполнению формы 6-НДФЛ» – сборник примеров заполнения нового отчета для самых разных ситуаций.
Подарок будет отправлен на Вашу почту сразу после регистрации.

У меня есть пароль
напомнить
Пароль отправлен на почту
Ввести
Я тут впервые
И получить доступ на сайт
Займет минуту!
Введите эл. почту или логин
Неверный логин или пароль
Неверный пароль
Введите пароль