Как подставить значения из одной таблицы в другую

5474
Очень неудобно, работая в Excel, «руками» переносить данные из одной таблицы в другую. Допустим, есть таблица с данными о продажах: дата отгрузки, название компании-покупателя, наименование приобретенной продукции и объем поставки в натуральных единицах. Прайс-лист, в котором указаны цены за единицу поставляемой продукции, существует отдельно. Задача: перевести в стоимост­ное выражение ежедневные продажи, то есть интегрировать в таблицу с данными о продажах цены из прайс-листа.

Очень неудобно, работая в Excel, «руками» переносить данные из одной таблицы в другую. Допустим, есть таблица с данными о продажах: дата отгрузки, название компании-покупателя, наименование приобретенной продукции и объем поставки в натуральных единицах. Прайс-лист, в котором указаны цены за единицу поставляемой продукции, существует отдельно. Задача: перевести в стоимост­ное выражение ежедневные продажи, то есть интегрировать в таблицу с данными о продажах цены из прайс-листа.

Сделать это без монотонной ручной работы позволяет стандартный инструмент Excel – функция вертикального просмотра «ВПР», которая автоматически сделает выборку и подставит нужные данные. Для этого в графу отчета, которая отведена под цены, надо ввести формулу «=ВПР(искомое значение; таблица; номер столбца; интервальный просмотр)».

1. Искомое значение – ячейка с данными, по которым нужно подобрать недостающие сведения из другой таблицы. В нашем примере это ячейка с наименованием товара.

2. Таблица – здесь нужно указать диапазон ячеек из другой таблицы, по которому будет проводиться поиск. Чтобы это значение задать, достаточно будет выделить прайс-лист при помощи мышки. Тут есть одна тонкость. Чтобы «ВПР» работала корректно, в прайс-листе первой колонкой должно быть наименование товара. Если это не так, то, выделяя таблицу, которую будет использовать «ВПР» как источник подстановки, надо начать именно со столб­ца с наименованиями.

3. Номер столбца – порядковый номер столбца в прайс-листе, из которого функция выберет данные о ценах. Указать необходимо именно номер столбца от начала таблицы. К примеру, если в прайс-листе первая колонка – наименование товаров, а вторая – цена, то в функцию необходимо ввести цифру 2.

4. Интервальный просмотр – для этого аргумента функции предусмотрено только два значения: «ИСТИНА» или «ЛОЖЬ». В первом случае функция будет искать по прайс-листу не точно соответствующее наименование, а похожее. Из-за этого возможны ошибки, поэтому лучше задать «ЛОЖЬ».

После того как вы ввели функ­цию, останется только скопировать ее во все ячейки отчета о продажах.

КСТАТИ. При копировании важно учитывать, что в формуле будут меняться ссылки на ячейки. Например, если копировать вниз формулу «=A1+B1», уже в следующей ячейке она примет вид «=A2+B2». А значит, в нашем примере данные о товаре из верхней ячейки не попадут в выборку. Чтобы избежать этого, используется знак доллара $. В случае с функцией «ВПР» это может выглядеть следующим образом «=ВПР(C1;$F$1:$E$35;2;ЛОЖЬ)», где $F$1:$E$35 – защищенная от изменения при копировании ссылка на прай-лист.

Есть вопрос? Наши эксперты помогут за 24 часа! Получить ответ Новое



Ваша персональная подборка

    Подписка на статьи

    Чтобы не пропустить ни одной важной или интересной статьи, подпишитесь на рассылку. Это бесплатно.

    Рекомендации по теме

    Школа финансового руководителя

    Самое выгодное предложение

    Проверь свои знания и приобрети новые

    Записаться

    Самое выгодное предложение

    Самое выгодное предложение

    Воспользуйтесь самым выгодным предложением на подписку и станьте читателем уже сейчас

    Живое общение с редакцией

    А еще...

    Вопрос в редакцию

    Ответы на самые интересные вопросы мы публикуем в газете.

    Вопрос чиновнику

    Горячие линии с чиновниками проходят еженедельно.

    Техподдержка

    Не работает сайт или сервисы? Не приходит газета? Пишите сюда!





    Топ-10 главных тем номера

    Как с 1 октября 2017 года оформлять счета-фактуры и вести книги по НДС

    Бухгалтерский справочник по исправлению ошибок в документах

    Как работать с онлайн-кассой после 1 июля 2017 года

    Как избежать случайных ошибок в расчете отпускных

    Как сверить налоговую нагрузку компании с безопасными показателями

    Готовые ответы на требования инспекторов по новой отчетности

    Почему блокируют клиент-банк. Реальные основания и мифы

    Как заполнять платежные поручения по взносам: новые правила

    Как компаниям платить налоги друг за друга, чтобы деньги попали в бюджет

    Бухгалтерские секреты, которые каждый день упрощают работу коллег

    © 2007–2017 ООО «Актион управление и финансы»

    Редакция газеты: info@gazeta-unp.ru | Администрация сайта: online@gazeta-unp.ru
    Политика конфиденциальности
    Зарегистрировано Федеральной службой по надзору в сфере связи, информационных технологий и массовых коммуникаций (Роскомнадзор). Свидетельство о регистрации ПИ № ФС77-62334 от 03.07.2015;
    Политика обработки персональных данных

    
    • Мы в соцсетях
    Сайт использует файлы cookie. Они позволяют узнавать вас и получать информацию о вашем пользовательском опыте. Это нужно, чтобы улучшать сайт. Если согласны, продолжайте пользоваться сайтом. Если нет – установите специальные настройки в браузере или обратитесь в техподдержку.

    Внимание!
    Вы читаете профессиональную статью для бухгалтера.
    Зарегистрируйтесь на сайте и продолжите чтение!

    Это бесплатно и займет 1 минуту.

    У меня есть пароль
    напомнить
    Пароль отправлен на почту
    Ввести
    Я тут впервые
    И получить доступ на сайт Займет минуту!
    Введите эл. почту или логин
    Неверный логин или пароль
    Неверный пароль
    Введите пароль
    ×
    Чтобы скачать документ, зарегистрируйтесь на сайте!

    Это бесплатно и займет всего 1 минуту.

    У меня есть пароль
    напомнить
    Пароль отправлен на почту
    Ввести
    Я тут впервые
    И получить доступ на сайт Займет минуту!
    Введите эл. почту или логин
    Неверный логин или пароль
    Неверный пароль
    Введите пароль